const regex = /([0-9]+)([\s]*)=>([\s]*)([1-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+)([\\s]*)=>([\\s]*)([1-9]+)', '')
const str = `1 => 1`;
const subst = `\1\2=>\3'\4'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);