re = /([0-9]+)([\s]*)=>([\s]*)([1-9]+)/
str = '1 => 1'
subst = '\\1\\2=>\\3\'\\4\''
result = str.sub(re, subst)
# Print the result of the substitution
puts result