$re = '/([0-9]+)([\s]*)=>([\s]*)([1-9]+)/';
$str = '1 => 1';
$subst = "\1\2=>\3'\4'";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;