use strict;
my $str = '1 => 1';
my $regex = qr/([0-9]+)([\s]*)=>([\s]*)([1-9]+)/p;
my $subst = '\\1\\2=>\\3\'\\4\'';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";