#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(\w+\b)[^>]*>([\S\s]*?)<\/\1>"
Local $sString = "if <p>TEXT</p> gsufgus <p>testesss</p> this is print: "TEXT gsufgus testesss" and i want print only : "TEXT testesss"" & @CRLF & _
"<p>fasfsd</p> and <h1>asfdf</h1>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")