using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+\b)[^>]*>([\S\s]*?)<\/\1>";
string input = @"if <p>TEXT</p> gsufgus <p>testesss</p> this is print: ""TEXT gsufgus testesss"" and i want print only : ""TEXT testesss""
<p>fasfsd</p> and <h1>asfdf</h1>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}