import re
regex = re.compile(r"<(\w+\b)[^>]*>([\S\s]*?)<\/\1>")
test_str = ("if <p>TEXT</p> gsufgus <p>testesss</p> this is print: \"TEXT gsufgus testesss\" and i want print only : \"TEXT testesss\"\n"
"<p>fasfsd</p> and <h1>asfdf</h1>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")