re = /<(\w+\b)[^>]*>([\S\s]*?)<\/\1>/
str = 'if <p>TEXT</p> gsufgus <p>testesss</p> this is print: "TEXT gsufgus testesss" and i want print only : "TEXT testesss"
<p>fasfsd</p> and <h1>asfdf</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end