$re = '/<(\w+\b)[^>]*>([\S\s]*?)<\/\1>/';
$str = 'if <p>TEXT</p> gsufgus <p>testesss</p> this is print: "TEXT gsufgus testesss" and i want print only : "TEXT testesss"
<p>fasfsd</p> and <h1>asfdf</h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);