# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:(?=:|$)/:0000/g;t' <<< "1050:::600:5:1000::"