import re
regex = re.compile(r":(?=:|$)")
test_str = "1050:::600:5:1000::"
subst = ":0000"
result = regex.sub(subst, test_str)
if result:
print(result)