import Foundation
let pattern = #":(?=:|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1050:::600:5:1000::"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":0000"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)