$re = '/:(?=:|$)/';
$str = '1050:::600:5:1000::';
$subst = ":0000";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;