using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(?=:|$)";
string substitution = @":0000";
string input = @"1050:::600:5:1000::";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}