#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->"
Local $sString = "{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!--# include file="/site_media/test2.js"-->" & @CRLF & _
"<!--# include file="/site_media/test.js"-->" & @CRLF & _
"<!--# include file='/site_media/media/test.js'-->" & @CRLF & _
"" & @CRLF & _
"<!--# include virtual="/shop/getstates/1"-->" & @CRLF & _
"<!--# include virtual="/css"-->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!--# include file='/site_media/test2.js'-->" & @CRLF & _
"<!--# include file='/site_media/test.js'-->" & @CRLF & _
"<!--# include file="/site_media/media/test.js"-->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" {# EXTRA_CSS #}" & @CRLF & _
" {% if website.var.obj.extra_css %}" & @CRLF & _
" <style type="text/css">" & @CRLF & _
" {{ website.var.obj.extra_css|safe }}" & @CRLF & _
" </style>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")