// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->"#).unwrap();
let string = "{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}
<!--# include file=\"/site_media/test2.js\"-->
<!--# include file=\"/site_media/test.js\"-->
<!--# include file='/site_media/media/test.js'-->
<!--# include virtual=\"/shop/getstates/1\"-->
<!--# include virtual=\"/css\"-->
<!--# include file='/site_media/test2.js'-->
<!--# include file='/site_media/test.js'-->
<!--# include file=\"/site_media/media/test.js\"-->
{# EXTRA_CSS #}
{% if website.var.obj.extra_css %}
<style type=\"text/css\">
{{ website.var.obj.extra_css|safe }}
</style>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}