using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--# include (\bvirtual\b|\bfile\b)=(\""|')(.+)(\""|').*-->";
string input = @"{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}
<!--# include file=""/site_media/test2.js""-->
<!--# include file=""/site_media/test.js""-->
<!--# include file='/site_media/media/test.js'-->
<!--# include virtual=""/shop/getstates/1""-->
<!--# include virtual=""/css""-->
<!--# include file='/site_media/test2.js'-->
<!--# include file='/site_media/test.js'-->
<!--# include file=""/site_media/media/test.js""-->
{# EXTRA_CSS #}
{% if website.var.obj.extra_css %}
<style type=""text/css"">
{{ website.var.obj.extra_css|safe }}
</style>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}