import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--# include (\\bvirtual\\b|\\bfile\\b)=(\\\"|')(.+)(\\\"|').*-->";
final String string = "{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}\n\n\n"
+ "<!--# include file=\"/site_media/test2.js\"-->\n"
+ "<!--# include file=\"/site_media/test.js\"-->\n"
+ "<!--# include file='/site_media/media/test.js'-->\n\n"
+ "<!--# include virtual=\"/shop/getstates/1\"-->\n"
+ "<!--# include virtual=\"/css\"-->\n\n\n"
+ "<!--# include file='/site_media/test2.js'-->\n"
+ "<!--# include file='/site_media/test.js'-->\n"
+ "<!--# include file=\"/site_media/media/test.js\"-->\n\n\n\n"
+ " {# EXTRA_CSS #}\n"
+ " {% if website.var.obj.extra_css %}\n"
+ " <style type=\"text/css\">\n"
+ " {{ website.var.obj.extra_css|safe }}\n"
+ " </style>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}