re = /<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->/
str = '{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}
<!--# include file="/site_media/test2.js"-->
<!--# include file="/site_media/test.js"-->
<!--# include file=\'/site_media/media/test.js\'-->
<!--# include virtual="/shop/getstates/1"-->
<!--# include virtual="/css"-->
<!--# include file=\'/site_media/test2.js\'-->
<!--# include file=\'/site_media/test.js\'-->
<!--# include file="/site_media/media/test.js"-->
{# EXTRA_CSS #}
{% if website.var.obj.extra_css %}
<style type="text/css">
{{ website.var.obj.extra_css|safe }}
</style>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end