use strict;
my $str = '{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}
<!--# include file="/site_media/test2.js"-->
<!--# include file="/site_media/test.js"-->
<!--# include file=\'/site_media/media/test.js\'-->
<!--# include virtual="/shop/getstates/1"-->
<!--# include virtual="/css"-->
<!--# include file=\'/site_media/test2.js\'-->
<!--# include file=\'/site_media/test.js\'-->
<!--# include file="/site_media/media/test.js"-->
{# EXTRA_CSS #}
{% if website.var.obj.extra_css %}
<style type="text/css">
{{ website.var.obj.extra_css|safe }}
</style>';
my $regex = qr/<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}