#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$"
Local $sString = "# Pods with indirect controllers, such as Deployment" & @CRLF & _
"coredns-bd44f767b" & @CRLF & _
"otel-collector-869d4bc96" & @CRLF & _
"" & @CRLF & _
"# Pods with direct controllers, such as StatefulSet" & @CRLF & _
"thanos-recieve" & @CRLF & _
"loki-ingester" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")