import re
regex = re.compile(r"^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$", flags=re.MULTILINE)
test_str = ("# Pods with indirect controllers, such as Deployment\n"
"coredns-bd44f767b\n"
"otel-collector-869d4bc96\n\n"
"# Pods with direct controllers, such as StatefulSet\n"
"thanos-recieve\n"
"loki-ingester\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")