using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$";
string input = @"# Pods with indirect controllers, such as Deployment
coredns-bd44f767b
otel-collector-869d4bc96
# Pods with direct controllers, such as StatefulSet
thanos-recieve
loki-ingester
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}