// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$").unwrap();
let string = "# Pods with indirect controllers, such as Deployment
coredns-bd44f767b
otel-collector-869d4bc96
# Pods with direct controllers, such as StatefulSet
thanos-recieve
loki-ingester
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}