package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$`)
var str = `# Pods with indirect controllers, such as Deployment
coredns-bd44f767b
otel-collector-869d4bc96
# Pods with direct controllers, such as StatefulSet
thanos-recieve
loki-ingester
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}