re = /^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$/m
str = '# Pods with indirect controllers, such as Deployment
coredns-bd44f767b
otel-collector-869d4bc96
# Pods with direct controllers, such as StatefulSet
thanos-recieve
loki-ingester
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end