import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9a-z-.]+?)(-[0-9a-f]{8,10})?$";
final String string = "# Pods with indirect controllers, such as Deployment\n"
+ "coredns-bd44f767b\n"
+ "otel-collector-869d4bc96\n\n"
+ "# Pods with direct controllers, such as StatefulSet\n"
+ "thanos-recieve\n"
+ "loki-ingester\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}