#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?):(.*?),'(.*?)',(.*?),(.*?),(.*?)$"
Local $sString = "COOP:166657,'NEW IBERIA AIRPORT ACADIANA REGIONAL LA US',200001,177,553" & @CRLF & _
"COOP:166884,'NEW LONDON AIRPORT ACADIANA REGIONAL LA US',200001,177,888"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")