using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?):(.*?),'(.*?)',(.*?),(.*?),(.*?)$";
string input = @"COOP:166657,'NEW IBERIA AIRPORT ACADIANA REGIONAL LA US',200001,177,553
COOP:166884,'NEW LONDON AIRPORT ACADIANA REGIONAL LA US',200001,177,888";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}