# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([[:alnum:]])\.([[:alnum:]])/\1/g;t' <<< "Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$."