#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([[:alnum:]])\.([[:alnum:]])"
Local $sString = "Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)