re = /([[:alnum:]])\.([[:alnum:]])/
str = 'Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$.'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result