import Foundation
let pattern = #"([[:alnum:]])\.([[:alnum:]])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)