const regex = /([[:alnum:]])\.([[:alnum:]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[:alnum:]])\\.([[:alnum:]])', 'g')
const str = `Names: \$annie.bettie.cindy.dannie.ellie\$. Only \$a\$ names. \$a.b.c.d.e.f\$.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);