package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([[:alnum:]])\.([[:alnum:]])`)
var str = `Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$.`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}