using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([[:alnum:]])\.([[:alnum:]])";
string substitution = @"\1";
string input = @"Names: $annie.bettie.cindy.dannie.ellie$. Only $a$ names. $a.b.c.d.e.f$.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}