# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((["'])(?:\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\\/(?![*\\/])(?:\\.|\[(?:\\.|.)\]|.)*?\\/(?=[gmiy]{0,4}\s*(?![*\\/])(?:\W|$)))|\\/\\/.*?$|\\/\*[\s\S]*?\*\\//$1/gm;t' <<< "var test = [
\"// Code\",
'// Code',
\"'// Code\",
'\"// Code',
//\" Comment\",
//' Comment',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ \"Code\",
\"Code\",
\"/* Code */\",
\"/* Code\",
\"Code */\",
'/* Code */',
'/* Code',
'Code */',
/* Comment
\"Comment\",
Comment */ \"Code\",
/Code\/*/,
\"Code */\"
];
Code = Code / Code /* Comment */ /g; // Comment
Code = /Code regex/g /* Comment */; // Comment
"