#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((["'])(?:\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\/(?![*\/])(?:\\.|\[(?:\\.|.)\]|.)*?\/(?=[gmiy]{0,4}\s*(?![*\/])(?:\W|$)))|\/\/.*?$|\/\*[\s\S]*?\*\/"
Local $sString = "var test = [" & @CRLF & _
" "// Code"," & @CRLF & _
" '// Code'," & @CRLF & _
" "'// Code"," & @CRLF & _
" '"// Code'," & @CRLF & _
" //" Comment"," & @CRLF & _
" //' Comment'," & @CRLF & _
" /* Comment */" & @CRLF & _
" // Comment /* Comment" & @CRLF & _
" /* Comment" & @CRLF & _
" Comment // */ "Code"," & @CRLF & _
" "Code"," & @CRLF & _
" "/* Code */"," & @CRLF & _
" "/* Code"," & @CRLF & _
" "Code */"," & @CRLF & _
" '/* Code */'," & @CRLF & _
" '/* Code'," & @CRLF & _
" 'Code */'," & @CRLF & _
" /* Comment" & @CRLF & _
" "Comment"," & @CRLF & _
" Comment */ "Code"," & @CRLF & _
" /Code\/*/," & @CRLF & _
" "Code */"" & @CRLF & _
"];" & @CRLF & _
" " & @CRLF & _
" Code = Code / Code /* Comment */ /g; // Comment" & @CRLF & _
" Code = /Code regex/g /* Comment */; // Comment" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)