using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([""'])(?:\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\/(?![*\/])(?:\\.|\[(?:\\.|.)\]|.)*?\/(?=[gmiy]{0,4}\s*(?![*\/])(?:\W|$)))|\/\/.*?$|\/\*[\s\S]*?\*\/";
string substitution = @"$1";
string input = @"var test = [
""// Code"",
'// Code',
""'// Code"",
'""// Code',
//"" Comment"",
//' Comment',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ ""Code"",
""Code"",
""/* Code */"",
""/* Code"",
""Code */"",
'/* Code */',
'/* Code',
'Code */',
/* Comment
""Comment"",
Comment */ ""Code"",
/Code\/*/,
""Code */""
];
Code = Code / Code /* Comment */ /g; // Comment
Code = /Code regex/g /* Comment */; // Comment
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}