use strict;
my $str = 'var test = [
"// Code",
\'// Code\',
"\'// Code",
\'"// Code\',
//" Comment",
//\' Comment\',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ "Code",
"Code",
"/* Code */",
"/* Code",
"Code */",
\'/* Code */\',
\'/* Code\',
\'Code */\',
/* Comment
"Comment",
Comment */ "Code",
/Code\\/*/,
"Code */"
];
Code = Code / Code /* Comment */ /g; // Comment
Code = /Code regex/g /* Comment */; // Comment
';
my $regex = qr/((["'])(?:\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\/(?![*\/])(?:\\.|\[(?:\\.|.)\]|.)*?\/(?=[gmiy]{0,4}\s*(?![*\/])(?:\W|$)))|\/\/.*?$|\/\*[\s\S]*?\*\//mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";