import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([\"'])(?:\\\\[\\s\\S]|.)*?\\2|(?:[^\\w\\s]|^)\\s*\\/(?![*\\/])(?:\\\\.|\\[(?:\\\\.|.)\\]|.)*?\\/(?=[gmiy]{0,4}\\s*(?![*\\/])(?:\\W|$)))|\\/\\/.*?$|\\/\\*[\\s\\S]*?\\*\\/";
final String string = "var test = [\n"
+ " \"// Code\",\n"
+ " '// Code',\n"
+ " \"'// Code\",\n"
+ " '\"// Code',\n"
+ " //\" Comment\",\n"
+ " //' Comment',\n"
+ " /* Comment */\n"
+ " // Comment /* Comment\n"
+ " /* Comment\n"
+ " Comment // */ \"Code\",\n"
+ " \"Code\",\n"
+ " \"/* Code */\",\n"
+ " \"/* Code\",\n"
+ " \"Code */\",\n"
+ " '/* Code */',\n"
+ " '/* Code',\n"
+ " 'Code */',\n"
+ " /* Comment\n"
+ " \"Comment\",\n"
+ " Comment */ \"Code\",\n"
+ " /Code\\/*/,\n"
+ " \"Code */\"\n"
+ "];\n"
+ " \n"
+ " Code = Code / Code /* Comment */ /g; // Comment\n"
+ " Code = /Code regex/g /* Comment */; // Comment\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}