const regex = /((["'])(?:\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\/(?![*\/])(?:\\.|\[(?:\\.|.)\]|.)*?\/(?=[gmiy]{0,4}\s*(?![*\/])(?:\W|$)))|\/\/.*?$|\/\*[\s\S]*?\*\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((["\'])(?:\\\\[\\s\\S]|.)*?\\2|(?:[^\\w\\s]|^)\\s*\\\/(?![*\\\/])(?:\\\\.|\\[(?:\\\\.|.)\\]|.)*?\\\/(?=[gmiy]{0,4}\\s*(?![*\\\/])(?:\\W|$)))|\\\/\\\/.*?$|\\\/\\*[\\s\\S]*?\\*\\\/', 'gm')
const str = `var test = [
"// Code",
'// Code',
"'// Code",
'"// Code',
//" Comment",
//' Comment',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ "Code",
"Code",
"/* Code */",
"/* Code",
"Code */",
'/* Code */',
'/* Code',
'Code */',
/* Comment
"Comment",
Comment */ "Code",
/Code\\/*/,
"Code */"
];
Code = Code / Code /* Comment */ /g; // Comment
Code = /Code regex/g /* Comment */; // Comment
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);