$re = '/((["\'])(?:\\\\[\s\S]|.)*?\2|(?:[^\w\s]|^)\s*\/(?![*\/])(?:\\\\.|\[(?:\\\\.|.)\]|.)*?\/(?=[gmiy]{0,4}\s*(?![*\/])(?:\W|$)))|\/\/.*?$|\/\*[\s\S]*?\*\//m';
$str = 'var test = [
"// Code",
\'// Code\',
"\'// Code",
\'"// Code\',
//" Comment",
//\' Comment\',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ "Code",
"Code",
"/* Code */",
"/* Code",
"Code */",
\'/* Code */\',
\'/* Code\',
\'Code */\',
/* Comment
"Comment",
Comment */ "Code",
/Code\\/*/,
"Code */"
];
Code = Code / Code /* Comment */ /g; // Comment
Code = /Code regex/g /* Comment */; // Comment
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;