#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[a-zA-Z])\?(?=[a-zA-Z])"
Local $sString = "Eg., "Okay?" should be "Okay?" and not "Okayfi"" & @CRLF & _
"" & @CRLF & _
"but" & @CRLF & _
"" & @CRLF & _
"Modi?es should be Modifies since it has ? in middle"
Local $sSubst = "fi"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)