const regex = new RegExp('(?<=[a-zA-Z])\\?(?=[a-zA-Z])', 'g')
const str = `Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle`;
const subst = `fi`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);