$re = '/(?<=[a-zA-Z])\?(?=[a-zA-Z])/';
$str = 'Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle';
$subst = "fi";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;