import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-zA-Z])\\?(?=[a-zA-Z])";
final String string = "Eg., \"Okay?\" should be \"Okay?\" and not \"Okayfi\"\n\n"
+ "but\n\n"
+ "Modi?es should be Modifies since it has ? in middle";
final String subst = "fi";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}