using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])\?(?=[a-zA-Z])";
string substitution = @"fi";
string input = @"Eg., ""Okay?"" should be ""Okay?"" and not ""Okayfi""
but
Modi?es should be Modifies since it has ? in middle";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}