import Foundation
let pattern = #"(?<=[a-zA-Z])\?(?=[a-zA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"fi"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)