use strict;
my $str = 'Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle';
my $regex = qr/(?<=[a-zA-Z])\?(?=[a-zA-Z])/p;
my $subst = 'fi';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";